The following is an actual function that we have defined this week in our server application for Flick Karts:
@Override
public void onFlick(Flick flick) {
race.flick(flick.id, flick.impulse);
server.flick(flick);
}
Of course, there is nothing wrong per se with this piece of code, but it amuses me that it almost sounds as if it were a tongue twister: “onFlick flick flick, race flick flick flick, server flick flick”.
It turns out that “flick” is a very important object in a flicking game. Who knew?